[krbdev.mit.edu #8672] KFW 4.1 credential cache issue

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[krbdev.mit.edu #8672] KFW 4.1 credential cache issue

Greg Hudson via RT-2
[[hidden email] - Wed Apr 25 09:16:14 2018]:

> We use memory cache type.

Thanks for the quick reply -- I don't think we know of any issues with
the memory cache type that could cause this behavior, so proceeding
with your original debugging plan seems wise.

Could you say a bit more about what build environment you are using and
what build instructions you are following?
 
In particular, what versions of (at least) windows, visual studio,
windows SDK, and perl are in use, as well as a pointer to the
documentation from which you are getting the build commands to run
(even if it is just the README in the source of the tarball).

Thanks,

Ben

> Thanks,
> Hong
>
> On 4/25/18, 8:12 AM, "Benjamin Kaduk via RT" <rt-
>    [hidden email]> wrote:
>
>     [[hidden email] - Tue Apr 24 12:15:01 2018]:
>
>     > Hello,
>     >
>     >
>     > We have an in house developed IIS extension that does
>    authentication
>     >    and authorization. We have a Windows 2012 server and have
KFW
>    4.1
>     >    installed. It works fine for single request. But when
sending

>     >    concurrent requests to IIS, it generated Kerberos error when
>     >    requesting Kerberos service ticket( function
>    gss_init_sec_context
>     >    is called )
>     >
>     >
>     >
>     > Here are the error in our log:
>     >
>     > “Credential cache is empty” or “No credentials cache
>    found”
>     >
>     > I would like to debug KFW code myself and tried to build the
>    source.
>     >    But I keep getting error when run nmake, any idea how to fix
>    the
>     >    build issue?
>     >
>     > Faulting application name: libecho.exe, version: 0.0.0.0, time
>    stamp:
>     >    0x5adf3b6a
>     > Faulting module name: ntdll.dll, version: 6.3.9600.18969, time
>    stamp:
>     >    0x5aa29ff0
>     > Exception code: 0xc0000005
>     > Fault offset: 0x000000000003b709
>     > Faulting process id: 0xb10
>     > Faulting application start time: 0x01d3dbdc839ddfe7
>     > Faulting application path: c:\kfw-
>     >    4.1\src\util\windows\obj\AMD64\dbg\libecho.exe
>     > Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
>     > Report Id: c14b17cb-47cf-11e8-81cd-0ea29ef5ed10
>     > Faulting package full name:
>     > Faulting package-relative application ID:
>
>     What credentials cache type is being used by the application
>    (e.g.,
>     FILE, LSA, etc.)?
>
>


_______________________________________________
krb5-bugs mailing list
[hidden email]
https://mailman.mit.edu/mailman/listinfo/krb5-bugs
Reply | Threaded
Open this post in threaded view
|

Re: [krbdev.mit.edu #8672] KFW 4.1 credential cache issue

Greg Hudson via RT-2
Thanks for your reply. I followed the instruction from the README in the source of the tarball. Here is my build environment:

Windows 2012 R2
Microsoft visual studio 12.0
Windows SDK 8
Perl 5.12.4

Thanks for your help,
Hong

On 4/25/18, 3:43 PM, "Benjamin Kaduk via RT" <[hidden email]> wrote:

    [[hidden email] - Wed Apr 25 09:16:14 2018]:
   
    > We use memory cache type.
   
    Thanks for the quick reply -- I don't think we know of any issues with
    the memory cache type that could cause this behavior, so proceeding
    with your original debugging plan seems wise.
   
    Could you say a bit more about what build environment you are using and
    what build instructions you are following?
     
    In particular, what versions of (at least) windows, visual studio,
    windows SDK, and perl are in use, as well as a pointer to the
    documentation from which you are getting the build commands to run
    (even if it is just the README in the source of the tarball).
   
    Thanks,
   
    Ben
   
    > Thanks,
    > Hong
    >
    > On 4/25/18, 8:12 AM, "Benjamin Kaduk via RT" <rt-
    >    [hidden email]> wrote:
    >
    >     [[hidden email] - Tue Apr 24 12:15:01 2018]:
    >
    >     > Hello,
    >     >
    >     >
    >     > We have an in house developed IIS extension that does
    >    authentication
    >     >    and authorization. We have a Windows 2012 server and have
    KFW
    >    4.1
    >     >    installed. It works fine for single request. But when
    sending
    >     >    concurrent requests to IIS, it generated Kerberos error when
    >     >    requesting Kerberos service ticket( function
    >    gss_init_sec_context
    >     >    is called )
    >     >
    >     >
    >     >
    >     > Here are the error in our log:
    >     >
    >     > “Credential cache is empty” or “No credentials cache
    >    found”
    >     >
    >     > I would like to debug KFW code myself and tried to build the
    >    source.
    >     >    But I keep getting error when run nmake, any idea how to fix
    >    the
    >     >    build issue?
    >     >
    >     > Faulting application name: libecho.exe, version: 0.0.0.0, time
    >    stamp:
    >     >    0x5adf3b6a
    >     > Faulting module name: ntdll.dll, version: 6.3.9600.18969, time
    >    stamp:
    >     >    0x5aa29ff0
    >     > Exception code: 0xc0000005
    >     > Fault offset: 0x000000000003b709
    >     > Faulting process id: 0xb10
    >     > Faulting application start time: 0x01d3dbdc839ddfe7
    >     > Faulting application path: c:\kfw-
    >     >    4.1\src\util\windows\obj\AMD64\dbg\libecho.exe
    >     > Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    >     > Report Id: c14b17cb-47cf-11e8-81cd-0ea29ef5ed10
    >     > Faulting package full name:
    >     > Faulting package-relative application ID:
    >
    >     What credentials cache type is being used by the application
    >    (e.g.,
    >     FILE, LSA, etc.)?
    >
    >
   
   
   



_______________________________________________
krb5-bugs mailing list
[hidden email]
https://mailman.mit.edu/mailman/listinfo/krb5-bugs