[krbdev.mit.edu #8672] KFW 4.1 credential cache issue

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[krbdev.mit.edu #8672] KFW 4.1 credential cache issue

Jeffrey Arbuckle via RT
Hello,


We have an in house developed IIS extension that does authentication and authorization. We have a Windows 2012 server and have KFW 4.1 installed. It works fine for single request. But when sending concurrent requests to IIS, it generated Kerberos error when requesting Kerberos service ticket( function gss_init_sec_context is called )



Here are the error in our log:

“Credential cache is empty” or “No credentials cache found”

I would like to debug KFW code myself and tried to build the source. But I keep getting error when run nmake, any idea how to fix the build issue?

Faulting application name: libecho.exe, version: 0.0.0.0, time stamp: 0x5adf3b6a
Faulting module name: ntdll.dll, version: 6.3.9600.18969, time stamp: 0x5aa29ff0
Exception code: 0xc0000005
Fault offset: 0x000000000003b709
Faulting process id: 0xb10
Faulting application start time: 0x01d3dbdc839ddfe7
Faulting application path: c:\kfw-4.1\src\util\windows\obj\AMD64\dbg\libecho.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: c14b17cb-47cf-11e8-81cd-0ea29ef5ed10
Faulting package full name:
Faulting package-relative application ID:

Thanks,
Hong Ye
Identity Management
CIT
Cornell University


_______________________________________________
krb5-bugs mailing list
[hidden email]
https://mailman.mit.edu/mailman/listinfo/krb5-bugs