build failure with openssl-1.1.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

build failure with openssl-1.1.0

Eray Aslan-2
openssl-1.1.0 was released on August 25, 2016.
  https://wiki.openssl.org/index.php/1.1_API_Changes
  https://www.openssl.org/news/changelog.html#x1

Trying to build krb5-1.14.3 with openssl-1.1.0 fails in at least pkinit
and k5tls modules.  Hopefully, someone has enough cycles to hava a look.

--
Eray
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos
Reply | Threaded
Open this post in threaded view
|

Re: build failure with openssl-1.1.0

Tom Yu
Eray Aslan <[hidden email]> writes:

> Trying to build krb5-1.14.3 with openssl-1.1.0 fails in at least pkinit
> and k5tls modules.  Hopefully, someone has enough cycles to hava a look.

There is an open pull request for openssl-1.1 compatibility:

    https://github.com/krb5/krb5/pull/447

This support will probably be in the upcoming krb5-1.15 release.

-Tom
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos