Warning message with app-crypt/mit-krb5-1.16.3 Gentoo Linux package

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Warning message with app-crypt/mit-krb5-1.16.3 Gentoo Linux package

Francesco Turco
Portage reports the following warning message when installing the app-crypt/
mit-krb5-1.16.3 package on my Gentoo Linux system:

> QA: prepare                                                                                                                                                              
> This package has a configure.in file which has long been deprecated.  Please                                                                                              
> update it to use configure.ac instead as newer versions of autotools will
die                                                                                            
> when it finds this file.  See https://bugs.gentoo.org/426262 for details.

--
https://fturco.gitlab.com/
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Warning message with app-crypt/mit-krb5-1.16.3 Gentoo Linux package

Greg Hudson
On 3/3/19 10:47 AM, Francesco Turco wrote:
>> QA: prepare                                                                                                                                                              
>> This package has a configure.in file which has long been deprecated.  Please                                                                                              
>> update it to use configure.ac instead as newer versions of autotools will
> die                                                                                            
>> when it finds this file.  See https://bugs.gentoo.org/426262 for details.

Thanks; I have submitted a PR to rename configure.in to configure.ac.

(I don't think we will need to worry about this soon.  automake plans to
remove support for configure.in in 2.0, but we don't use automake.
autoconf hasn't had a release in years, so while there is a 2012 commit
adding a deprecation warning for configure.in, the most recent release
still doesn't warn.  But the cost of renaming is fairly low.)
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos