Re: krb5 1.4 on AIX 5.1 Illegal Instruction

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: krb5 1.4 on AIX 5.1 Illegal Instruction

Donn Cave
In article <[hidden email]>,
 Donald Thompson <[hidden email]> wrote:

> I'm getting an 'Illegal Instruction' when I try to kinit using krb5 1.4 on
> AIX 5.1. I've tried compiling
> using both the IBM XL C Compiler, as well as gcc 3.3 with the same result.
> I've had no problems compiling
> and using krb5 1.3 versions. Anyone know if theres a fix for this?
>
> -Don

In case anyone is still set back by this one, I tracked
it to res_nsearch.  On our AIX platforms (I was looking
at 5.2, but 4.3 looks the same) this function overwrites
a much larger area than the declared size of its input
struct __res_state.  I don't know if this would be true
for everyone, or if it's a patch my hosts happen to have.
SRV lookups work better if the configure scripts don't find
res_nsearch.

Also, AIX 5 defines AI_NUMERICSERV, which has implications
for MIT's getaddrinfo wrapper.

   Donn Cave, [hidden email]
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos