Installing SAP on Linux snckrb5.so unable to compile.

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing SAP on Linux snckrb5.so unable to compile.

Nitin Salunkhe
Hello

I am facing same error as per group question open by Vusa Moyo can you
please help me with solution

<server_Host>:/usr/sap/SNC/sncadapt # make
./build."`uname -s`" make do-all
make[1]: Entering directory '/usr/sap/SNC/sncadapt'
make[1]: Circular snckrb5 <- snckrb5 dependency dropped.
make[1]: Circular .o <- snckrb5 dependency dropped.
gcc -g -DXDEBUG=1  -ldl -lnsl -lpthread -lc    -ldl -o .c
/usr/lib64/gcc/x86_64-suse-linux/4.8/../../../../lib64/crt1.o: In function
`_start':
/home/abuild/rpmbuild/BUILD/glibc-2.22/csu/../sysdeps/x86_64/start.S:114:
undefined reference to `main'
collect2: error: ld returned 1 exit status
<builtin>: recipe for target '.c' failed
make[1]: *** [.c] Error 1
make[1]: Leaving directory '/usr/sap/SNC/sncadapt'
Makefile:35: recipe for target 'all' failed
make: *** [all] Error 2


Regards,
Nitin Salunkhe
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos
Reply | Threaded
Open this post in threaded view
|

Re: Installing SAP on Linux snckrb5.so unable to compile.

Benjamin Kaduk-2
On Fri, Aug 02, 2019 at 01:49:15AM +0200, Nitin Salunkhe wrote:
> Hello
>
> I am facing same error as per group question open by Vusa Moyo can you
> please help me with solution

Are you referring to the post from that individual back from 2006?  Any
insight gained at that time is unlikely to remain current.

Since you provided no details about the sources or makefile you are
attempting to build with, I cannot comment on the details thereof.  That
said, my research while producing https://github.com/kaduk/osxsnc led me to
believe that SAP is quite happy to accept a libgssapi_krb5.so directly as a
SNC adapter (barring the ABI issue on macOS that led to that project).  So
I'm not entirely certain why you need to build anything at all, on linux.

-Ben
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos
Reply | Threaded
Open this post in threaded view
|

Re: Installing SAP on Linux snckrb5.so unable to compile.

Nitin Salunkhe
In reply to this post by Nitin Salunkhe
Thanks Benjamin for your reply

I have manged to create this build :)

regards,
Nitin Salunkhe


On Sun, Aug 4, 2019 at 7:38 AM Benjamin Kaduk <[hidden email]> wrote:

> On Fri, Aug 02, 2019 at 01:49:15AM +0200, Nitin Salunkhe wrote:
> > Hello
> >
> > I am facing same error as per group question open by Vusa Moyo can you
> > please help me with solution
>
> Are you referring to the post from that individual back from 2006?  Any
> insight gained at that time is unlikely to remain current.
>
> Since you provided no details about the sources or makefile you are
> attempting to build with, I cannot comment on the details thereof.  That
> said, my research while producing https://github.com/kaduk/osxsnc led me
> to
> believe that SAP is quite happy to accept a libgssapi_krb5.so directly as a
> SNC adapter (barring the ABI issue on macOS that led to that project).  So
> I'm not entirely certain why you need to build anything at all, on linux.
>
> -Ben
>
________________________________________________
Kerberos mailing list           [hidden email]
https://mailman.mit.edu/mailman/listinfo/kerberos